Lösung: Bootloop durch Xposed-Modul

Wer sein Smartphone gern mal modded kommt fast zwangsläufig nicht um das Xposed Framework mit den entsprechenden Modulen herum.

Gestern wollte ich mal wieder ein neues Modul ausprobieren und habe natürlich profimäßig überlesen, dass man vorher ein Backup anlegen solle. Es kam, wie es kommen musste und ich hatte eine Art Bootloop und bekam nach einem Neustart zwar noch das Wallpaper auf dem S7 edge zu sehen, aber mehr ging dann auch nicht. Kein drücken irgendwelcher Tasten und nicht einmal ein booten in den Safe-Mode half.

Theoretisch würde ich nun in das TWRP-Recovery booten und dort entweder das System zurücksetzen, oder direkt gleich noch ein neues ROM flashen. Dabei gehen dann meistens die installierten Apps nebst dazugehörigen Daten flöten und alles muss wieder frisch installiert werden. Also grob gesagt zwar eine Lösung, aber keine gute Lösung.

Freund Google half mir aber weiter, denn es gibt einen Workaround für mein Problem. Einfach gesagt, wird eine Config-Datei gelöscht, und schon lädt das Xposed-Framework kein Modul mehr beim starten des Gerätes.

Dies funktioniert wie folgt:

  • Booten des Smartphones in das TWRP-Recovery
  • Über Advanced den File-Manager aufrufen
  • Nun in das folgende Verzeichnis navigieren: /data/data/de.robv.android.xposed.installer/conf/
  • Die Datei modules.list anklicken und via drücken von delete löschen.

Das war es auch schon! Anschließend einfach neu starten und hoffen, dass alles wieder läuft! In meinem Fall hat das problemlos funktioniert und mir viel Arbeit erspart. Nun konnte das fehlerhafte bzw. nicht funktionierende Modul einfach gelöscht werden und alles war wieder in Ordnung.

Was lernen wir daraus? IMMER EIN BACKUP ANLEGEN! Nicht immer gibt es eine so einfache Lösung. :)

Teilen

Hinterlasse deine Meinung
Du kannst auch als Gast kommentieren (Anleitung). DISQUS respektiert „Do Not Track“ und bietet einen Datenschutz-Modus an. Informationen zum Datenschutz auf mobiFlip.de findest du hier.